Using the m68k-atari-mint cross-tools on Debian GNU/Linux

The only supported version is Debian 9 "Stretch" 64-bit.

Tip: Looking for Ubuntu packages? See there.

  1. Add my public key to your APT trusted key list.
    This is required to avoid security warnings when you install a package from my repository.
    wget -qO - | sudo apt-key add -
  2. Add the following lines at the end of your /etc/apt/sources.list file:
    deb [arch=amd64] stretch contrib
    deb-src stretch contrib
  3. Update your packages index files:
    sudo apt update
  4. Install the cross-tools meta-package:
    sudo apt install cross-mint-essential
  5. You are ready to use the cross-compiler!
    m68k-atari-mint-gcc hello.c -o hello.tos
  6. You may also want to install the optional libraries:
    sudo apt install cflib-m68k-atari-mint
    sudo apt install ldg-m68k-atari-mint
    sudo apt install sdl-m68k-atari-mint
    sudo apt install ncurses-m68k-atari-mint
    sudo apt install zlib-m68k-atari-mint
    sudo apt install readline-m68k-atari-mint
    sudo apt install openssl-m68k-atari-mint

Back to the m68k-atari-mint page